Some email Delivery and Configuration Disruptions
Incident Report for Artsy
Resolved
Our external provider has fixed the issue on their end and our services are back up.
Posted Apr 29, 2024 - 22:51 EDT
Identified
The issues have been identified and it's being fixed at the moment.
Posted Apr 29, 2024 - 10:28 EDT
Update
We are continuing to investigate this issue.
Posted Apr 29, 2024 - 10:26 EDT
Investigating
We are currently experiencing a disruption in some email delivery and e-mail configuration services due to a performance issue with an external service provider. This is affecting our ability to send alerts, offer emails, and configure e-mail notifications.
Posted Apr 29, 2024 - 10:24 EDT
This incident affected: Artsy.net Website (E-commerce).