Artsy.net is experiencing sporadic instability.
Incident Report for Artsy
Resolved
This incident has been resolved.
Posted May 15, 2019 - 18:49 EDT
Monitoring
Artsy.net is operational and we are continuing to monitor for any regression from the earlier incident.
Posted May 15, 2019 - 18:28 EDT
Update
We are continuing to investigate this issue.
Posted May 15, 2019 - 18:24 EDT
Investigating
We are currently investigating this issue.
Posted May 15, 2019 - 18:06 EDT
This incident affected: Artsy.net Website (Content, E-commerce).