Unable to submit Buy Now orders at MASS MoCA Benefit Auction

Incident Report for Artsy

Resolved

We determined a data entry issue causing the order processing to fail. The issue only affected Buy Now works for this specific auction.
Posted Oct 29, 2019 - 21:48 EDT

Investigating

We are currently investigating this issue.
Posted Oct 29, 2019 - 20:51 EDT