Email services impacted
Incident Report for Artsy
Resolved
We have identified the problem, rolled out a fix, and verified it is working.
Posted Oct 01, 2019 - 13:06 EDT
Update
We are continuing to work on a fix for this issue.
Posted Oct 01, 2019 - 13:05 EDT
Identified
We have identified and are investigating a fix for a problem with Artsy's email services. For the time being, emails sent through Artsy's systems may be delayed.
Posted Oct 01, 2019 - 09:57 EDT
This incident affected: Artsy API.