Occasional errors or latency from Artsy.net
Incident Report for Artsy
Resolved
This incident has been resolved.
Posted Jul 09, 2019 - 09:59 EDT
Monitoring
We are currently monitoring the latency and errors on Artsy.net.
Posted Jul 08, 2019 - 16:13 EDT
Investigating
We are currently investigating this issue.
Posted Jul 08, 2019 - 13:49 EDT
This incident affected: Artsy.net Website (Content).