Transactional emails may be delayed or unavailable due to Sendgrid outage
Incident Report for Artsy
Resolved
Sendgrid has implemented a fix and is monitoring on their end. After investigating, we do not believe any emails to Artsy users were dropped, though some may have been delayed.
Posted Jul 28, 2020 - 16:03 EDT
Monitoring
Sendgrid has updated their status page and notes that some mail may be stuck waiting for delivery but that most functionality should be operational: https://status.sendgrid.com/

We believe that emails are working as expected but are still unable to log in to Sendgrid to verify.
Posted Jul 28, 2020 - 14:57 EDT
Investigating
Sendgrid, which we use to send transactional emails, is experiencing degraded service: https://status.sendgrid.com/

We're investigating to determine the full impact on Artsy systems
Posted Jul 28, 2020 - 13:33 EDT
This incident affected: Artsy.net Website (E-commerce, Auctions Bidding, Partners), Artsy Content Management System (CMS) (Conversations), and Artsy for iPhone.