Artsy Android: Google Sign Up issues
Incident Report for Artsy
Resolved
This incident has been resolved.
Posted Jul 19, 2022 - 12:49 EDT
Update
We are continuing to investigate this issue.
Posted Jul 19, 2022 - 11:59 EDT
Investigating
We are currently investigating this issue.
Posted Jul 19, 2022 - 11:59 EDT
This incident affected: Artsy for Android.