Degraded performance in search

Incident Report for Artsy

Resolved

All systems are now operating normally.
Posted Oct 20, 2025 - 06:32 EDT

Update

We are continuing to investigate this issue.
Posted Oct 20, 2025 - 06:18 EDT

Investigating

We are seeing degraded performance in search on artsy.net and other clients. We are investigating the issue.
Posted Oct 20, 2025 - 06:16 EDT
This incident affected: Artsy for iPhone, Artsy for Android and Artsy.net Website (Content).