CMS: Artwork Form issues for edition sets
Incident Report for Artsy
Resolved
The incident has been resolved.
Posted Apr 05, 2022 - 09:35 EDT
Monitoring
A fix has been deployed to production for the CMS artwork form issues related to edition sets. We are monitoring production.
Posted Apr 05, 2022 - 07:28 EDT
Identified
The CMS artist page is now loading properly.

We identified the issues with updating edition sets data using the Artwork Form. We are currently working on a fix.
Posted Apr 05, 2022 - 06:37 EDT
Investigating
We are currently experiencing issues with the Content Management System's artist page and the artwork form. Investigations are ongoing.
Posted Apr 05, 2022 - 05:36 EDT
This incident affected: Artsy Content Management System (CMS) (Content Management).