Errors during payment and credit card operations
Incident Report for Artsy
Resolved
This incident has been resolved.
Posted Jul 10, 2019 - 19:07 EDT
Update
Users are currently experiencing intermittent errors from credit card and payment operations, due to errors from the Stripe payment API. See https://status.stripe.com/ for more details.
Posted Jul 10, 2019 - 18:07 EDT
Identified
Credit card operations such as sale registration and payment are currently experiencing errors.
Posted Jul 10, 2019 - 17:36 EDT
This incident affected: Artsy.net Website (E-commerce, Auctions Bidding) and Artsy for iPhone.