Many Artsy.net pages showing 500 errors
Incident Report for Artsy
Resolved
We have resolved the issue.
Posted Jun 07, 2019 - 17:19 EDT
Update
We are continuing to investigate this issue.
Posted Jun 07, 2019 - 17:10 EDT
Investigating
We are currently investigating this issue.
Posted Jun 07, 2019 - 16:31 EDT
This incident affected: Artsy.net Website (Content, E-commerce, Auctions Bidding).