Elevated error rates and response times on artsy.net

Incident Report for Artsy

Resolved

All systems are now operating normally.
Posted Oct 16, 2025 - 13:01 EDT

Monitoring

The period of high latency and 5xx errors has concluded. All systems are now operating normally. We will continue to monitor to ensure continued stability.
Posted Oct 16, 2025 - 10:03 EDT

Investigating

We’re currently investigating elevated error rates and response times within artsy.net and the mobile app. We’ll post an update soon.
Posted Oct 16, 2025 - 09:10 EDT
This incident affected: Artsy.net Website (Content).