Images not loading or significantly delayed
Incident Report for Artsy
Resolved
This incident has been resolved.
Posted Mar 31, 2020 - 08:36 EDT
Update
Amazon CloudFront is experiencing high error rate which is affecting image loading on the Artsy site.
Posted Mar 30, 2020 - 19:55 EDT
Investigating
We are currently investigating this issue.
Posted Mar 30, 2020 - 19:53 EDT
This incident affected: Artsy Content Management System (CMS) (Content Management), Artsy.net Website (Content, E-commerce, Auctions Bidding, Partners), and Artsy for iPhone.