artsy.net is down

Incident Report for Artsy

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 13:19 EST

Monitoring

Artsy services have recovered and availability has returned to expected levels. We'll continue monitoring the Cloudflare outage for any further disruption.
Posted Nov 18, 2025 - 08:42 EST

Identified

An upstream service we rely on (Cloudflare) is "experiencing an internal service degradation". We'll continue to monitor their incident resolution status. We expect our own services to recover as soon as they're back up and running.

For more details on the Cloudflare outage, you may visit their status page: https://www.cloudflarestatus.com/incidents/8gmgl950y3h7
Posted Nov 18, 2025 - 07:52 EST

Update

We are continuing to investigate this issue.
Posted Nov 18, 2025 - 07:26 EST

Investigating

We’re currently investigating elevated error rates and response times within artsy.net and the mobile app. We’ll post an update soon.
Posted Nov 18, 2025 - 07:25 EST
This incident affected: Artsy Content Management System (CMS) (Content Management, Conversations, Analytics), Artsy.net Website (Content, E-commerce, Auctions Bidding, Partners), and Artsy API.