Artsy.net is unstable
Incident Report for Artsy
Resolved
This incident has been resolved.
Posted Aug 04, 2020 - 22:58 EDT
Monitoring
We are continuing to monitor the issue but have mitigated things and the site is responding.
Posted Aug 04, 2020 - 22:29 EDT
Update
We are continuing to investigate this issue.
Posted Aug 04, 2020 - 22:11 EDT
Investigating
We are currently investigating this issue.
Posted Aug 04, 2020 - 21:29 EDT
This incident affected: Artsy for iPhone and Artsy.net Website (Content).